ZESCO

From Chalo Chatu, Zambia online encyclopedia
Jump to navigation Jump to search
ZESCO
Type
Public
IndustryElectricity Generation and Supply
Founded1970
HeadquartersLusaka, Zambia
RevenueUS$ 250 million (2007)
Number of employees
3,600 (2007)
Parentstate owned
Websitewww.zesco.co.zm

ZESCO (formerly known as Zambia Electricity Supply Corporation Limited) is a state-owned power company in Zambia. It is Zambia's largest power company producing about 80% of the electricity consumed in the country. ZESCO represents Zambia in the Southern African Power Pool.

Operations

The company operates 9 hydropower stations with a combined capacity of 2,217.5 MW and eight small thermal power plants with a combined capacity of 11.3 MW resulting in a total installed capacity of 2,228.8 MW.[1]

The company also owns and operates power distribution and transmission lines of 9,975 km.

Power stations

A new station at the Itezhi-Tezhi Dam with 120 MW capacity is due for commissioning in 2015 or 2016.

Limitations

The national grid in Zambia only extends to some parts of the country. For example, it ends 380 kilometres (240 mi) from the Ikelenge area around Kalene Hill in the extreme northwest, and as of 2008 ZESCO had no plans to provide power to this remote area. In response, some small-scale private operations have been established such as the Zengamina 700KW hydro generator.[2] The Energy Regulation Board is encouraging private investment in hydro power generation in view of the power deficit.[3]

References

  • Lua error in ...ribunto/includes/engines/LuaCommon/lualib/mwInit.lua at line 23: bad argument #1 to 'old_ipairs' (table expected, got nil).

Notes

<templatestyles src="Reflist/styles.css" />

  1. Lua error in ...ribunto/includes/engines/LuaCommon/lualib/mwInit.lua at line 23: bad argument #1 to 'old_ipairs' (table expected, got nil).
  2. Lua error in ...ribunto/includes/engines/LuaCommon/lualib/mwInit.lua at line 23: bad argument #1 to 'old_ipairs' (table expected, got nil).
  3. Lua error in ...ribunto/includes/engines/LuaCommon/lualib/mwInit.lua at line 23: bad argument #1 to 'old_ipairs' (table expected, got nil).

External links